LetsSingIt インターネット歌詞データベース
ja
5
Back to old website

Site upgrade - bugs and change requests

フォローする 2
Megosztani
トピックを追加
探す
Ray
3
Ray | 13:22
This is a support page for the site upgrade, read more about this here: Site Upgrade – Beta Version Launched!.

Below is a list with known bugs and change requests and their status.

If you found a new bug or would like to submit a change request, please let me know by leaving a comment in this topic.

Bugs

[open] Remove content without approving other content
If content is added that already exists and you use the remove / already exists option, the remove option should take care of all the other content and no manual review should be needed.
Status: unsolved
[open] Cropping pictures
When cropping an uploaded picture by using the zoom option in combination with the dragging function, the picture may not be copped as presented in the preview.
Status: unsolved
[open] Review notifications don't work for rejected content
When submitted content completed review and was rejected, the notification doesn't work.
Status: unsolved
[closed] Loading a picture made system hang.
When loading a picture over a non-secure HTTP connection, the system should raise an alert.
Status: solved
[closed] The edit-form of the "about" song/album is not working.
Status: solved
[closed] The album link is empty wen reviewing an album removal request.
When reviewing an album removal request, the link to the correct album remains empty.
Status: solved
[closed] Pressing Enter key shows error page
On the "Download from Internet" form, pressing the Enter key shows an error page.
Status: solved
[closed] Pictures won't load correctly
Picture that succecsfully loaded in the old system don't load anymor ein the new system.
Status: solved
[closed] Changing the capitalization of an artist name gives duplicate error
The new system doesn't recognize changing the capitalization of an artist name, an duplicte error is shown.
Status: solved
[closed] Reviewing an album gives infinite load symbol when tracklist contains special quotes
When opening the review form for a new or improved album that has non-standard quotes in the tracklist, you run into an infinite loading symbol.
Status: solved
[closed] Link in my-content don't work for new content
After adding a song or album, the link in my-content don't work.
Status: solved
[closed] Album and song cover don't load after move
When moving an album or song to another artist, the cover (if exists) won't load. The remove functionality has been disabled until this issue has been fixed.
Status: solved
[closed] Review notifications don't work
When content you submitted has been reviewed, the notification with the review results doesn't work.
Status: solved
[closed] New artists don't appear correctly in searchengine
After adding an artist and looking up this artist in the searchengine, the search results are blank. There is a search result for the artist, but no name or other text is displayed.
Status: solved
[closed] Infinite loading review button
When clicking on the review button while no items are in the review-queue, the page hangs ("infinite loading").
Status: solved
[closed] Prepublished content appears as "improvement" in queue
When content is pre-published on the site (i.e. already added to the site, but still under review) it appears in the review queue as "improvement". it should actually appear as "new".
Status: solved
[closed] Header styling incorrect
The new header styling is not always displayed properly.
Status: solved
[closed] Review queue popup doesn't close
When you open an item to review from the review list, the review list doesn't close. After reviewing the item, a new review list is opened. The result is that you end up with multiple popups that you have to close.
Status: solved
[closed] Infinite loading after reviewing
When reviewing an item in review the page hangs ("infinite loading").
Status: solved
[closed] The resource button does nothing when you click on it
The "Resources"-button on the CMS form doesn't do anything when you click on it. The button has been removed.
Status: solved

Change requests

Update Museum
Update the LSI Museum Site with the 2009 through 2022 site design.
Update Sitemap
Update the sitemap.
Reinstall back and forward tabs on albums
On song pages the back- and forward tabs on albums whoud be reinstalled.
Make gallery pictures accessible for header-pictures
Make gallery pictures accessible for header-pictures
Rebuild header-picture from old system
The header pictures from the old system don't look nice in the new layout because the new system stretches these images. A rebuild of thes pictures should fix the problem.
1 から 2553 反応
ページ 1 / 3
roxcyn
2
roxcyn | 13:23
I have a few to add:

- There are two review queues now: the old version and the beta version. I think it's very annoying having to switch back and forth between the two.
- After every item I review it hangs on the buffer symbol and I have to refresh the page.
- I went to add songs titles on an existing album and it submitted the change to the queue as blank. Not sure what happened.
Ray
3
Ray | 13:35
There are two review queues now: the old version and the beta version. I think it's very annoying having to switch back and forth between the two.


Agree, fixing the bugs in the new CMS is in progress. When the new CMS is ready, the old will be removed from the site.

After every item I review it hangs on the buffer symbol and I have to refresh the page.


Working on it

I went to add songs titles on an existing album and it submitted the change to the queue as blank. Not sure what happened.


Working on it
PracticePractic
2
Great job! Lots of improvements to site!

Is this where I report a very tiny spelling error? (missing letter "w")

Its just your (Ray's) own page, not the site error..

On thread: Site Upgrade, Beta Version Launched!

Category: Album and song covers

It's no[w] possible to add covers to songs and albums. Nice!
PracticePractic
1
A comment on your progress report above ^ ^ ^

Bugs


When cropping an uploaded picture by using the zoom option, the picture may not be copped as presented in the preview.
Status: unsolved


That is my complaint I assume... I should add for everyone to know, its NOT a design fault of new CMS or site..

This is a longstanding loading image and editing for Top Header problem that since it seems (from asking others here) that I'm the only one who noticed it I didn't want to disturb your programming efforts by posting it before...

Hopefully it has a easy "aiming" fix (If I was coding, I'd just extend the blue dot/line of the edit page to the "left side" the zoom capability so it can SHRINK the image too.. When you first post the image, it just starts at one size..and Zoom only goes one way..........BIGGER
What if I want it "smaller"? To fit inside the top header area!

[I can try to draw the image using Paint, and post to a new thread to show you on the Top Header exactly what I mean in my words above........
Oh sorry (I'm joking, but seriously...) I can't show you the problem as the Top Header won't let me post a sufficiently complete image that is able to show you what a solution would look like!]

Remember..... you have many more tabs and words in that newly re-designed top header area......

Thus I have to move all images very carefully to avoid having something important hidden by the words describing the page or tab choices etc...

Which is WHY I felt its time I come out and complain about it since its more critical than ever before we have a method to adjust our images and see exactly how they look before posting them!!!

Just helping if I can, without going into the depths of coding an answer!
roxcyn
2
roxcyn | 02:08
In the beta queue the resource button (I assume it goes to our resources we used before ) does nothing when you click on it.

To add to my previous bug on my old post - after you're done with the entire queue of items (no more items to review) it makes you click each time for each review you have done. That is highly annoying. I assume if I refresh it would all go away, but still.
Ray
2
Ray | 14:22
Thanks guys for stress-testing the new system!

Is this where I report a very tiny spelling error? (missing letter "w")


Yes, this is teh right place. Thanks, nice catch!

What if I want it "smaller"? To fit inside the top header area!


Smaller is not possible. The picture is presented at its smallest size possible, because either the width or height hit the minimum required size. Therefore the picture can only be made larger.

In the beta queue the resource button (I assume it goes to our resources we used before) does nothing when you click on it


Working on that. I removed the button until it this has been resolved.

after you're done with the entire queue of items (no more items to review) it makes you click each time for each review you have done.


Added to the buglist.
MCSMeister
2
MCSMeister | 16:55
I still have yet to fully explore this new design, but wanted to post this here instead of making a new thread - it looks like this is the centralized thread for new bugs anyway.

It looks like there's an issue with updating an artist's header picture. I tried updating the header for Pale Waves with a newer image 10 minutes ago, as you can see in the activity feed, and it hasn't changed yet. Might be a cache issue, as is usually the case with similar bugs.
Ray
1
Ray | 17:12
It looks like there's an issue with updating an artist's header picture. I tried updating the header for Pale Waves with a newer image 10 minutes ago, as you can see in the activity feed, and it hasn't changed yet. Might be a cache issue, as is usually the case with similar bugs.


I think you used to old system to upload a new header image. The old system deleted the header_picture, the new system thinks it's still there. Result, an 404 / blank header.

The new header options are only available in the new system, so if you use the the new system for pictures (header-, profile-, and cover pictures), everything will be fine.

The half-old/half-new options are not an ideal solution. Once the new system has been polished, I'll phase out the old system, perhaps some options sooner than others.
MCSMeister
1
MCSMeister | 17:24
Ah I see, I indeed have been using the old design this week, mainly because I still need to set aside time to learn about the new layout and how to use it, because it's going to take some time to adapt to this (like anything).

I'm not sure I'm understanding how adding header pictures works on the new site, though. I tried adding it and it's saying it needs to be "reviewed". I read in the announcement post that you're doing away with the concept of "super moderators" and that our ability to edit metadata will depend on reliability level - but does this mean we're all starting from square one now, no matter how long we've been on the site?
Ray
1
Ray | 18:01
I tried adding it and it's saying it needs to be "reviewed"


Approved! The picture are live now.

does this mean we're all starting from square one now


No, that is not necessary at all For the moment we're all on square one, but this is because we're still testdriving the new system. It took a few days to get the upgrade working, but we're going into the right direction! Once we go full throttle, your privileges from the old system are transferred to the new system.
MCSMeister
1
MCSMeister | 18:28
Okay good, that's a relief to hear! Great to see that the new header gets rid of the old grid overlay immediately - I know this will eventually be removed for all pages, but I assume that as of now, this only applies to newly-added headers.

I guess my only other question currently is how long you plan on having the new layout in "test drive" mode, because as I'm sure you understand, this will make certain contribution features a bit of a pain at the moment, especially since there's no notification that contributions in the new layout have been reviewed. And I see this is on your bug list, but this basically means that as of now, I have to remember to go back and check that certain contributions have been reviewed, adding an unnecessary step to the process.

Of course, I also know that there's no hard and fast timeframe for these things, and the real answer is probably "whenever it's polished enough to go live", but I'm still curious if you have a rough ETA in mind.
Ray
2
Ray | 18:49
but I'm still curious if you have a rough ETA in mind


Looking at what's on the bug list now (hopefully no serious bugs are reported that need time to fix) and looking the work it needs to flip the entire site to the new design, I think I need .. say ... 2 weeks?
MCSMeister
0
MCSMeister | 18:53
That's a reasonable timeframe - I was more worried that we'd be stuck in this state for months, not weeks, so that sounds much more manageable. Obviously I know things happen and it could very well take more than 2 weeks, but I'm sure you want to roll out this new design and phase out the old one ASAP, so you probably don't want it to stay in this awkward limbo state for too long.
Ray
1
Ray | 19:05
I was more worried that we'd be stuck in this state for months


No worries While developing the beta version I made sure most of the functionalities were added, working and tested. That's why it took so long The beta version is not very different than the final upcoming release.
PracticePractic
2
Looking at what's on the bug list now (hopefully no serious bugs are reported that need time to fix) and looking the work it needs to flip the entire site to the new design, I think I need .. say ... 2 weeks?


Well, I guess its not too early then to add this small, hopefully more enjoyable task to your list of activities in next few weeks:

"Updating the LSI Museum Site"

With the 2009 through 2022 site design!
PracticePractic
1
Another one?

Site Map---might already be on your list

Member Menu
where it says "Sign In" (I checked on a new sign in via a browser so your site does not recognize me)

Still the example for first time visitors says "Sign in with Facebook" but the actual version we have been using for past few years, is a smaller sized sign in menu, and no longer says Sign in with Facebook. I recall somewhere a discussion when that particular sign in option was removed...so should the example that is on site map be altered to reflect the modern sign in?
PracticePractic
1
Oh I missed another small spelling error on the News page: Site Upgrade, Beta Version Launched!

Feedback


If you find a bug of have a change request,


again a one letter change to "r"

If you find a bug or have a change request
PracticePractic
1
Under the "Contribute" button (mine says 99--guess there is no room for 100, 101 yet)

It has listed under "Review" that there are 44 items there... no wait .. now its 22... no wait .. ITS LIVE! Great! Don't touch that one!

It has listed under something called "Quick Start" (I can't provide a link to that menu window so you have to find it yourself) (Did I miss seeing that elsewhere?)

Two questions: That "Quick Start" has no "number" for how many lyrics or other items to review under that category.

And why is it called "Quick Start"? Should it not be "Lyrics" or some other name? As "Review" category seems to be mostly the photos and other items from the Song and Album pages.....[Or maybe I'm looking at it wrong, just one day's worth, so lyrics, song titles, etc will eventually repopulate that setting for review again, correct?]

THANK YOU! so much for allowing me to pick and choose (and skip!) over the ones that I have no ability in a foreign language to determine if lyrics are correct or not. Now I (and others) will be able to concentrate on the items that we are best suited for evaluating and reviewing to help LSI grow bigger and better!

THANK YOU! BEDANKT!
PracticePractic
1
Ok, I wrote four good ones (you liked them) above...didn't want to post a "dud" correction.....but I see some reason to let others know about this, and if they also experience it, then
maybe.... I have two items:

Perhaps its something to correct? But only for a little while --the two systems are working side by side.

1. In the OLD website, the review it told me I had "4" to review...I did one....
Still told me I had "4"

OK, its a bug.. I switched to the NEW Website while staying on same song page I was interrupting my work to do a "review".......and lo and behold! The NEW website announced I have 23 to review (none of them I can do right now, to see if it goes down to 22, as really tight on time today, but not so tight I can't post this quick note (sorry for any grammar errors as I typed/thought too fast!)

No screen shots, I'll try next time (for now the review (button(s)) are showing me choices I don't have a clue to make a decision on ).

And of course I can't post a photo as playing back and forth, it settled down to showing I have 3 left of the 4 to review on the OLD Website.... But honestly unless you're ready to switch back and forth a time or two each time we do some activity, I'll view and enjoy things using the NEW site for now, and if I make any votes, or reviews or changes I'll go back to the OLD to do them as I read all your warnings about some features not working yet--not going to fight the Internet.. its bigger than both of us!

To save you re-writing some of your answer here, I know you have already responded to that item above in response to roxcyn's comment :

There are two review queues now: the old version and the beta version. I think it's very annoying having to switch back and forth between the two.


2. I think you mentioned this earlier in another thread (am I recalling another dimension perhaps?) That you said to me a feature for a future LSI "escaped" from the lab.... you fixed that errant code..... long ago. This [#2] is not that problem!

But I refer back to that sentence you wrote in Support, wherever its hiding---and saying that I notice that "some" of the features of the NEW website have "escaped" from the NEW and mingled into the OLD......its mostly design elements or small song or artist photos---where they had a prior presence now there is a lack of them,--- but the empty [shows a musical note on grey background] holding spots are clearly designed in the manner of how the NEW site shows...

And with those design elements on the OLD [!] version I saw several PHOTOS without the "grid overlay", but when I went to explore them further, they quickly vanished like the "will-o'-the-wisp" that these new improvements are... so I can't show them to you!

So I posted #2 in case others are noticing anything "escaping" and want to report it, else I think its either my not remembering differences or something wrong with my Google Chrome---it says it wants to update FYI, I've not had time....so again "my fault" so far....

~ ~ ~
As I stated right off at the top, these are nothing major, just some things bleeding across the two Website designs, and it all will settle down when there is just "one" merged NEW site for 2022 onward!

Keep on going!
roxcyn
1
roxcyn | 13:29
Will we be grandfathered in with our status or will we have to prove ourselves with the new system? Thanks.

I'd like to go back to the resources button. No, no, and no! Please don't delete it as you said that would be the appropriate solution. I LIKE it to be in the queue as we work and it goes to the usually resources that we check. Please and thank you.
MCSMeister
2
MCSMeister | 15:10
Will we be grandfathered in with our status or will we have to prove ourselves with the new system? Thanks.


Ray already answered this earlier :

Once we go full throttle, your privileges from the old system are transferred to the new system.
roxcyn
2
roxcyn | 02:00
That's cool, thanks Nicolas. I missed that part.
Ray
3
Ray | 17:04
The moderator privileges have been transferred to the new system!
Ray
2
Ray | 17:21
Thank for you input Practice! Below you'll find my answers.

Update the LSI Museum Site" with the 2009 through 2022 site design.


Added to the change-request list.

Site Map---might already be on your list


Updating the sitemap, also added to the change-request list.

Still the example for first time visitors says "Sign in with Facebook" but the actual version we have been using for past few years, is a smaller sized sign in menu, and no longer says Sign in with Facebook. I recall somewhere a discussion when that particular sign in option was removed...so should the example that is on site map be altered to reflect the modern sign in?


I'm not aware of two different login forms. There is just one login form on LetsSingIt, and that one is with a "Sign in with Facebook" button.

It has listed under something called "Quick Start" (I can't provide a link to that menu window so you have to find it yourself) (Did I miss seeing that elsewhere?)


The Quick Start is the "Most wanted" list that was listed under the old site.

That "Quick Start" has no "number" for how many lyrics or other items to review under that category.


It doesn't have a number because these are no song that are in the review queue. It's a list with songs that have no lyrics.

And why is it called "Quick Start"?


Some users want to contribute, but don't want to work on a speficic song, album or arist. They basicalle ask, how can I help? The Quick start is the list to start, it mentions content where help is needed. Later, more is added to this page, think like somthing like the "content checker" we had on the old site for artists. What about a content checker for all artists?

In the OLD website, the review it told me I had "4" to review...I did one.... Still told me I had "4"


No idea, prehaps one was exactly added in the teim you did your review?

There are two review queues now: the old version and the beta version. I think it's very annoying having to switch back and forth between the two.


Yup, that's annoying for sure. I think in a couple of weeks I'll flip the site to the new version (but with an option to flip bakc to the old site, for if you need a little more time getting used to the new layout

features of the NEW website have "escaped" from the NEW and mingled into the OLD


Yes, some new features are also visible in the old layout.
roxcyn
2
roxcyn | 05:38
New review queue doesn't open and keeps buffering.
guest
guest
飛び出す 保存する megtakarítás ...
続きを読む: